Stripe Customer stream fails at normalization

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu,
  • Memory / Disk: you can use something like 4Gb / 1 Tb
  • Deployment: EKS
  • Airbyte Version: 0.39.17
  • Source name/version: Stripe 0.1.33
  • Destination name/version: Snowflake 0.4.28
  • Step: Normalization

Stripe customer card fails at normalization

2022-06-21 23:48:28 normalization > 23:48:28  Completed with 1 error and 0 warnings:
2022-06-21 23:48:28 normalization > 23:48:28  
2022-06-21 23:48:28 normalization > 23:48:28  Database Error in model CUSTOMERS_CARDS (models/generated/airbyte_tables/STRIPE_NEW/CUSTOMERS_CARDS.sql)
2022-06-21 23:48:28 normalization > 23:48:28    100069 (22P02): Error parsing JSON: unknown keyword "list", pos 5
2022-06-21 23:48:28 normalization > 23:48:28    compiled SQL at ../build/run/airbyte_utils/models/generated/airbyte_tables/STRIPE_NEW/CUSTOMERS_CARDS.sql

Full logs: logs-468.txt (2.0 MB)

Jagannath this version of Airbyte had an issue with normalization, could you try to upgrade to 0.39.20+?

Thanks @marcosmarxm , does 0.39.20 have any breaking changes from 0.39.17? We’ve had multiple issues with upgrading in the past so just want to make sure

No, the upgrade to 0.39.20 should be only a patch update.

@marcosmarxm I’ve upgraded it to the latest version 0.39.24 and it fails with the same error.

logs-9.txt (285.4 KB)

The strange part is there is no list field, or type for the object Cards inside Customers.
I found this Stack Overflow:
Did you try to run one time or multiple times? It always fails?

I’ve ran the pipeline multiple times and it fails with the same error.

Sorry the long delay Jagannath, I wan’t able to reproduce your issue. What is the configuration in Snowflake you’re using? Internal Staging or using AWS/GCS?

Jagannath can you update your schema? Click in Refresh Source Schema

We are using Snowflake internal staging and yes, I did refresh the schema multiple times.

I created the issue to further investigation Jagannath. I wasn’t able to reproduce the issue