Airbyte API Server Returning 404 for endpoint

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: Ubuntu 20.04
  • Memory / Disk: you can use something like 70GB / 500GB
  • Deployment: Docker
  • Airbyte Version: 0.40.15

I have deployed airbyte and prefect 2.0 on a VM using docker. I’m trying to trigger a connection sync using prefect-airbyte.

Unfortunately I cannot get it to work in the server compared to my local workstation docker desktop.

Both airbyte and prefect versions are the same. See below result in prefect

Here is the airbyte-server logs

I was thinking if there could be an issue with the endpoint in prefect-agent but It is working on docker desktop. so I’m not sure.

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey don’t think that should be the case but could remove the last / and try again?

Unfortunately I cannot control the URL since it’s being build by prefect-airbyte library

I’ve done additional testing to try to do calls to the api and I still got 404 responses, this time via postman

Server log

Apologies I was able to get the API working you may ignore. since I was able to access, there could be an issue with the server

1 Like

I tried falling back to a lower airbyte version v0.40.10 but the issue still persist in terms of a docker container with prefect unable to access airbyte-server

Realized what the problem was now, it’s just that I put the wrong connection id.