Cannot reach server. The server may still be starting up

Hello Experts,

I am deploying airbyte using helm chart(s) on k8s

All the POD(s) are up and running fine. No error reported in console logs.

$ kubectl get pod
NAME                                                    READY   STATUS      RESTARTS       AGE
airbyte-db-0                                            1/1     Running     1 (2d4h ago)   2d4h
airbyte-minio-0                                         1/1     Running     0              2d4h
airbyte-poc-airbyte-bootloader                          0/1     Completed   0              2d4h
airbyte-poc-connector-builder-server-76f4cd4d56-pvvjz   1/1     Running     0              2d4h
airbyte-poc-cron-7f5887bbb4-jfn7r                       1/1     Running     0              2d4h
airbyte-poc-pod-sweeper-pod-sweeper-5f7df54649-wxmht    1/1     Running     0              2d4h
airbyte-poc-server-5f654cc96f-zzxvs                     1/1     Running     0              2d4h
airbyte-poc-temporal-cc4bdfc9c-2x7jr                    1/1     Running     0              2d4h
airbyte-poc-webapp-77bb956f-dzpjt                       1/1     Running     0              22h
airbyte-poc-worker-f698cf94d-448z5                      1/1     Running     0              2d4h

While accessing the UI getting “Cannot reach server. The server may still be starting up.” which looks like common error but couldn’t find what could be the reason I am able to reach airbyte server from the airbyte webapp.

/ # env | grep -i 8001

$ kubectl exec -it airbyte-poc-webapp-77bb956f-dzpjt sh
/ # curl

Can anyone pls provide some input for further troubleshooting?


Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

How are you trying to access the UI? Have you setup ingress ? Are you able to access the UI via portforward ?

Hi @VIKRANT, are you still experiencing this issue?

Hello @natalyjazzviolin yes.

Hello, im experiencing the same issue when deploying on an EC2 instance in AWS.

Everything is setup and running but i cant access the UI.

Has anyone solved this?

1 Like

Currently getting the same error on EC2. Our current setup is Airbyte version 0.42.0 and t3.Large deployed using the docker compose suggested in the docs. Everything was previously working until recently and now the only page that is displayed is the “Cannot reach server” error.

Hi Vikrant.

Just curious, where did you find the version of your Airbyte?

Hi I am having the same issue, but using the bash to boot up airbyte using docker compose. All services are running but docker logs airbyte-server | grep ERROR. and docker logs airbyte-worker | grep ERROR both return empty messages.

I am currently using a Mac M1 chip to deploy. The only log issue is a warning log, appears in both worker and server

2023-04-25 13:20:30 WARN i.a.c.t.TemporalUtils(getTemporalClientWhenConnected):259 - Waiting for namespace default to be initialized in temporal...
2023-04-25 13:20:32 INFO i.t.s.WorkflowServiceStubsImpl(<init>):86 - Created WorkflowServiceStubs for channel: ManagedChannelOrphanWrapper{delegate=ManagedChannelImpl{logId=99, target=airbyte-temporal:7233}}
2023-04-25 13:20:42 WARN i.a.c.t.TemporalUtils(getTemporalClientWhenConnected):269 - Ignoring exception while trying to request Temporal namespace:
io.grpc.StatusRuntimeException: DEADLINE_EXCEEDED: Deadline CallOptions will be exceeded in 9.999291042s.

Could you please help to investigate? Many thanks