Configuring Tolerations for orchestrator-repl-job in Airbyte on EKS


Airbyte jobs on EKS not applying tolerations to orchestrator-repl-job despite configuring JOB_KUBE_TOLERATIONS in config map. orchestrator-repl-job not deployed via Helm. How to configure tolerations/selectors for orchestrator-repl-job in Airbyte?


Hi Team,
We have airbyte running since long on EKS but currently we were making some infra changes such that all EKS nodes have taints.
All other Airbyte jobs work fine and are scheduled properly after configuring JOB_KUBE_TOLERATIONS option in airbyte config map but tolerations are not applied on orchestrator-repl-job jobs. Its not deployed via helm (helm list output is empty). Any idea how can we configure toleration/selector for orchestrator-repl-job job in airbyte?

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want
to access the original thread.

Join the conversation on Slack

["airbyte", "eks", "tolerations", "orchestrator-repl-job", "config-map", "helm"]