Connecting to Airbyte API server via Terraform provider in EKS cluster without a domain name


The user wants to connect to the Airbyte API server in an EKS cluster using Terraform provider without a domain name. They provided their current configuration for the API server.



I have deployed airbyte in my EKS cluster and can access the webapp using an elastic IP. I now want to be able to connect to the api server via Terraform provider so that I can create sources, destinations, etc. Given that I have don’t have my own domain name and using Airbyte OSSm what is the optimal way of configuring this? My current configuration for my api server is as follows:

enabled: true

– Number of airbyte-api-server replicas

replicaCount: 1

# – The repository to use for the airbyte airbyte-api-server image.
repository: airbyte/airbyte-api-server
# – The pull policy to use for the airbyte airbyte-api-server image
pullPolicy: IfNotPresent

# – Enable livenessProbe on the server
enabled: true
# – Initial delay seconds for livenessProbe
initialDelaySeconds: 30
# – Period seconds for livenessProbe
periodSeconds: 10
# – Timeout seconds for livenessProbe
timeoutSeconds: 10
# – Failure threshold for livenessProbe
failureThreshold: 3
# – Success threshold for livenessProbe
successThreshold: 1

# – Enable readinessProbe on the server
enabled: true
# – Initial delay seconds for readinessProbe
initialDelaySeconds: 10
# – Period seconds for readinessProbe
periodSeconds: 10
# – Timeout seconds for readinessProbe
timeoutSeconds: 10
# – Failure threshold for readinessProbe
failureThreshold: 3
# – Success threshold for readinessProbe
successThreshold: 1

airbyte-api-server resource requests and limits


We usually recommend not to specify default resources and to leave this as a conscious

choice for the user. This also increases chances charts run on environments with little

resources, such as Minikube. If you do want to specify resources, uncomment the following

lines, adjust them as necessary, and remove the curly braces after ‘resources:’.

## Example:
## limits:
## cpu: 200m
## memory: 1Gi
# – The resources limits for the airbyte-api-server container
limits: {}
## Examples:
## requests:
## memory: 256Mi
## cpu: 250m
## - The requested resources for the airbyte-api-server container
requests: {}

# – The log level to log at.
level: “INFO”

env_vars: {}
type: NodePort
port: 8006
nodePort: 30006

- Configure the ingress resource that allows you to access the Airbyte API, see

# – Set to true to enable ingress record generation
enabled: false
# – Specifies ingressClassName for clusters >= 1.18+
className: “nginx”
# – Ingress annotations done as key:value pairs
annotations:| nginx
#| “true”
# – The list of hostnames to be covered with this ingress record.
- paths:
- path: /
pathType: ImplementationSpecific
name: airbyte-api-server
number: 8006
# - secretName: chart-example-tls
# hosts:
# - chart-example.local

Any help with the above would be much appreciated!


This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["airbyte-api-server", "terraform-provider", "eks-cluster", "no-domain-name", "configuration"]