Custom GAQL not working in google ads source setup

  • s this your first time deploying Airbyte?: No
  • OS Version / Instance: MacOS
  • Memory / Disk: you can use something like 4Gb / 1 Tb
  • Deployment: I’m using airbyte cloud
  • Airbyte Version: What version are you using now?
  • Source name/version: google ads
  • Destination name/version: s3
  • Step: sync
  • Description: Hi support, I set up my first custom GAQL in one of my google ads source, this is the query that I’m using

SELECT, segments.keyword.ad_group_criterion, FROM search_term_view

and it goes to destination(which is set up to be s3) test_search_terms

but when I synced the data, I don’t see the new report generated, and I also didn’t see any output in the log file that’s related to search_term_view, am I missing something here?

Attached is the log file for this sync
logs-248265.txt (22.3 KB)

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Did you enable the new stream? You must refresh the schema to see the new custom report

Thanks for the reply! I tried to refresh the schema and still didn’t see the new stream showing up, this is my custom GAQL setup:

what did you do to get the custom_performance_max_campaign stream to show up? Thanks

I created a new source from scratch and now the new schema is showing up, does it mean I can’t added custom streams after a source has already been created?

You can without any problems Enkri. Nice you’re able to fix the issue!