EKS pods running into Pending state due to PV

Hey Team,
I’m running Airbyte on EKS and 3 pods keep running into Pending state with the same Event,
Warning FailedScheduling 35s default-scheduler 0/1 nodes are available: 1 node(s) had volume node affinity conflict. It gets fixed when I resize the airbyte-volume-configs persistent volume. Initially from 500Mi to 2Gi and then later pulled it to 20Gi too. Still facing this issue. Is there a suggestive volume that needs to be configured? Or is there a way to reclaim the volume if this is temporary?

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey @mukulg-df, could you tell me what version of Airbyte you’re on?

@natalyjazzviolin The airbyte version being used is: 0.40.14

Hi again Mukul, I see that you have also opened a thread on Slack:

Please note that double posting goes against our code of conduct:

Keeping questions to one thread helps our small team stay organized :slight_smile: I am closing this thread and let’s continue on Slack.

Hey @natalyjazzviolin I see that you have mentioned that you will continue the thread in slack, and on slack I see that you will be continuing in the forum. Please clarify.

Sorry about that, I must have found multiple threads in Slack!

Let’s continue here.

Hey @natalyjazzviolin, any pointers on the request?

Hey Mukul, I see a community member had some pointers on this:

The issue is the affinity conflict. Something afaik that is AWS specific. Basically, each AWS region has a few Availability zones. EC2 instances usually are just assigned a region, so the AZ it’s in is not certain (I’m pretty sure this is true, at least it was for me and my limited understanding of things). Sometimes the AZ doesn’t match the original AZ that the volume was created in, so you have an affinity conflict. There are two ways to solve this that I know of.

  1. Make sure you’re running at least one instance in each AZ. The easiest way is to set the min_size on the autoscaling group for the instance to the amount of AZs in the region you’re using.
  2. Replace postgres and minio with RDS and S3, so you don’t need to have Persistent Volumes anymore. Then you don’t have to worry about that at all.

Have you tried this already, and did it help?