Error connecting to Typesense destination from Airbyte Docker container


The user is facing an error while trying to add Typesense as a destination in Airbyte from a Docker container. The error message indicates a connection refusal to the localhost:5432. The user has tried using both ‘localhost’ and ‘’ as the hostname but the issue persists.


I am trying to implement a task where I have to sync data between postgres instance running on my local machine, and typesense instance running in a container on my machine.
I am using Airbyte through a docker container. I have successfully setup the source, but failing to add the destination, which is typesense. I have several time tried to resolve the issue but getting this error “State code: 08001; Message: Connection to localhost:5432 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.”
I have tried putting up the localhost name “localhost” and aslo “”, but failed to resolve this issue. Can you please help?

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["sync-data", "postgres-instance", "typesense-instance", "docker-container", "connection-error", "localhost", ""]