Error when testing SharePoint source connection with Docker test

Summary

When trying to use the SharePoint source connector, encountering an error during the Docker test connection. Consider using an SSL cert instead of a secret for authentication as Microsoft may be moving towards blocking new apps with client secrets.


Question

howdy - i’ve run into a weird problem, I’m looking at trying to use the sharepoint source, and I’ve configured permissions as documented, when i go to save / test connections i get an error that the docker test failed.
I’ve tried the sharepoint credentials in code and they fail.
Looking at the sharepoint admin screen it was advising to use an ssl cert instead of a secret. In my script that worked.
I don’t know if MSFT are just blocking new apps with client secrets but it seems that they want to move apps that direction.



This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want
to access the original thread.

Join the conversation on Slack

["sharepoint-source", "docker-test", "authentication", "ssl-cert", "client-secret"]