Error with invalid resume token when configuring MongoDB Source


When configuring a MongoDB Source in Airbyte, encountering an error related to an invalid resume token. The error message indicates a ‘ChangeStreamFatalError’ with code 280, stating that the resume token was not found. Recreating the connection and source does not resolve the issue. Using Atlas Mongo as the Source.


Hi all, I’m trying to configure a Mongodb Source but always getting a error about invalid resume token.

source > com.mongodb.MongoQueryException: Command failed with error 280 (ChangeStreamFatalError): 'Executor error during getMore :: caused by :: cannot resume stream; the resume token was not found.
I already tried to recreate the connection and the source always with the same error.

I’m using an Atlas Mongo as Source for this.

Anyone have thoughts about that?


This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["mongodb-source", "invalid-resume-token", "change-stream-fatal-error", "atlas-mongo", "connection-error"]