Failed to load schema in discovery_schema timeout in LoadBalancer

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu 22.04.1 LTS
  • Deployment: Docker
  • Airbyte Version: 0.40.06
  • Source name/version: MongoDB 0.1.17
  • Destination name/version: Google Bigquery 1.2.1
  • Step: Creating new connection, and refreshing source schema on existing connections
  • Description:

When refreshing existing connections (that have not had issues for weeks), the screen is stuck on this screen with the message " Please wait a little bit more… We are fetching the schema of your data source. This should take less than a minute, but may take a few minutes on slow internet connections or data sources with a large amount of tables."

When creating a connector between mongoDB and bigquery I get the error “failed to fetch schema”

server-logs(4).txt (1.6 MB)

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

I didn’t find any errors in your server logs. Do you mind track the API response in the network tab in your web browser?

Is this what you mean by “track the API response?”

There looks like there are two 504 errors when I create a new connection. The file name is “discover schema” where the error occurs

Yes, please check the Response tab.

the response says “upstream request timeout”

You must increase the timeout configured for your server.
Probably the connector is taking a long time to read all mongo collections.
My recommendation is try to limit the User access to only the necessary collections, and if you have large connections divide into multiple users.

1 Like

Hi marcosmarxm,
We don’t use the nginx before the airbyte or you mean we edit the timeout configuration on airbyte/webapp of airbyte docker-compose and beside that, we also don’t use the nginx/proxy before mongodb. Please help us clarify about this

Yep, are you using a LB to access Airbyte?

yes, we tried on LB and it can access for now.
Thank you

1 Like