Fetching data from Azure Table Storage to Postgres

Hello there, we’re trying airbyte and we want to get data from an azure table storage to a postgres and transform it through dbt.

When we create the connection we can replicate just fine, but as its noSQL it dumps every field of a row inside a single field, and we would like to be able to have it with each field having the orignal name, is there a lab somewhere explaining how to do it? We’re having trouble finding documentation about it.

Also, is replication needed for dbt to transform that data? Or can we do it without replicating?

Sorry if this sounds kinda stupid, but we’re new with the product and dbt overall, thanks beforehand!

EDIT: After some testing, we’ve started facing a problem where custom dbt transformations block the proccess, at least using the helm chart-installed version, i didnt try with any other version though

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

It seems my problem was related to this issue: Fix Operations API on Kube: Refactor normalization transform_config into Java · Issue #5091 · airbytehq/airbyte · GitHub

Connecting to the postgres database manually and doing the dbt run command manually worked.

I guess the solution would be to create a dbt pod that starts the dbt run command every hour to keep it all updated

Hey, @drodriguez! So glad to hear you were able to find a solution.