Helm Chart Deployment Question for Airbyte with flags.yml


Deploying Airbyte using Helm chart and passing a specific value for heartbeat.failSync from flags.yml file.


Got a helm chart question. If I wanted to helm deploy airbyte ensuring that the value of heartbeat.failSync in the flags.yml was passed, would it look something like:
helm install --values values.yaml --values flags.yml -n <NAMESPACE> --create-namespace <NAMESPACE> airbyte/airbyte

should I concatenate flags.yml and values.yaml into a single values file.

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["helm-chart", "airbyte", "flags.yml", "values.yaml", "deployment"]

After playing with a local docker install, I see that flags.yml gets mounted as /flags … I am not sure of an equivalent way to do this with a kubernetes volume mount

Hello Jason, unfortunetaly in the Kubernetes deployment you can’t modified the default values.yml Team is working to make it possible :pray:

I’d find out it’s possible to edit the entry directly in the database table connection you can give a try :smile:

kewl … I will look at that :grin:

hi, good morning! i am having exactly the same issue

is there some workaround to add the flags to helm? i am hitting a constant error on one of the connectors:
Heartbeat has stopped. Heartbeat freshness threshold: 3600 secs Actual heartbeat age: 3613 secs

so i wanted to either increase the threshold or disable it

Hi <@U01MMSDJGC9>,
I’ve been reviewing the “connection” table in the Airbyte 0.52 database and I can’t find where to configure what you mentioned. Could you provide more details on how to do it? If it’s not too much trouble, I’d really appreciate your help.

Hello <@U06HFFPTN21>, were you able to solve it?

<@U047CMHLV5Z> <@U06M88BGD6U> we pulled a newer version of the helm chart (airbyte-0.54.69, app version 0.50.56). In that version the default value for heartbeat.failSync is false. So far, that has been working for us

<@U06HFFPTN21> Thanks, where in the code or changelog can I verify that it is false?