Issue creating Google Drive source programmatically using Airbyte API


Unable to create a Google Drive source programmatically using Airbyte API, encountering ‘value-not-found’ error for source type ‘source-google-drive’. Successfully created a Slack source using the API.


I am using airbyte to get data out of my google drive and put it in weaviate. I was able to do POC by manually creating the connecotr.
But I want to create the source, destination and connection programatically.
I used airbyte-api to do this, I am able to create the destination successfully. But with source google-drive I am getting an issue.

URL: <http://localhost:8006/v1/sources>

Request Body:

  "configuration": {
    "sourceType": "source-google-drive",
    "credentials": {
      "auth_type": "Client",
      "client_id": "123",
      "client_secret": "123",
      "refresh_token": "123"
    "streams": [
        "globs": [
        "validation_policy": "Skip Record",
        "days_to_sync_if_history_is_full": 3,
        "format": {
          "filetype": "unstructured",
          "processing": {
            "mode": "local"
          "skip_unprocessable_files": true,
          "strategy": "fast"
        "schemaless": false,
        "name": "gDrive",
        "primary_key": "document_key"
    "folder_url": "<>"
  "name": "gDrive",
  "workspaceId": "3663eef6-5bcd-4b63-9ecf-9f5d6215d785"

  "type": "<>",
  "title": "value-not-found",
  "status": 400,
  "detail": "Submitted value could not be found: source-google-drive"

I tried to create another source like Slack from api and that worked fine.
Any help is appreciated, if you can point me to the code as well, I can debug and fix this. Thanks```



This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. [Click here]( if you want to access the original thread.

[Join the conversation on Slack](

["google-drive-source", "airbyte-api", "value-not-found", "source-type-error"]

Hey Ragav, I guess you are using Airbyte Desktop right?

It looks like this is the error:

Resource Not Found is raised when the id presented in the request cannot be found for the given resource type. For instance, if a UUID of a Connection does not match a Connection in a Workspace that the Access Token has access to, then the Resource Not Found error will be raised.```