Issue with orchestrator pod not starting during sync in Airbyte v0.50.43 on k8s


The user is facing an issue where the orchestrator pod is not starting during sync in Airbyte v0.50.43 on k8s. They temporarily resolved it by setting CONTAINER_ORCHESTRATOR_ENABLED to False. They are seeking advice on a more robust solution and potential risks of disabling the container orchestrator.


Hi everyone,
I have been facing this issue for a while now and it is solved but not sure how robust the solution is.
message='io.temporal.serviceclient.CheckedExceptionWrapper: io.airbyte.workers.exception.WorkerException: Running the launcher replication-orchestrator failed', type='java.lang.RuntimeException', nonRetryable=false
what worked for me was to set CONTAINER_ORCHESTRATOR_ENABLED to False.
While troubleshooting, I could see that the temporal pod is running fine but is unable to start the orchestrator pod when I trigger a sync. and also saw 2 orchestrators with state “error”

Did anyone face the same issue and solved it permanently in a better way? Or does anyone know if there are any risks with disabling the container orchestrator?
I am running the latest version of airbyte v0.50.43 on k8s

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["orchestrator-pod", "sync-issue", "airbyte-v0.50.43", "k8s", "container-orchestrator"]