Issue with setting up connections for custom low-code connector in Airbyte


The user is facing an error ‘Discovering schema failed’ when trying to set up connections using a custom low-code connector for Webshipper built using the builder. The error ‘Internal Server Error: Cannot invoke…’ is also encountered when trying to refresh the schema of existing connectors. Other custom connectors work fine, but the new one consistently throws the same error.


I am facing a weird issue for my custom low-code connector for Webshipper that I have built using the builder.
It works fine when I am testing and I have previously been able to setup connectors and sources using it.
I am able to setup sources with it, but as soon as I try to setup a connections using the source I get the following error:
Discovering schema failed

2024-03-07 11:08:12 platform > Executing worker wrapper. Airbyte version: 0.50.49
2024-03-07 11:08:12 platform > Attempt 0 to save workflow id for cancellation
2024-03-07 11:08:12 platform > Using default value for environment variable SIDECAR_KUBE_CPU_LIMIT: '2.0'
2024-03-07 11:08:12 platform > Using default value for environment variable SOCAT_KUBE_CPU_LIMIT: '2.0'
2024-03-07 11:08:12 platform > Using default value for environment variable SIDECAR_KUBE_CPU_REQUEST: '0.1'
2024-03-07 11:08:12 platform > Using default value for environment variable SOCAT_KUBE_CPU_REQUEST: '0.1'
2024-03-07 11:08:12 platform > Using default value for environment variable LAUNCHDARKLY_KEY: ''
2024-03-07 11:08:12 platform > Checking if airbyte/source-declarative-manifest:0.61.2 exists...
2024-03-07 11:08:12 platform > airbyte/source-declarative-manifest:0.61.2 was found locally.
2024-03-07 11:08:12 platform > Creating docker container = source-declarative-manifest-discover-86a82371-6cf2-461a-9955-570e93244f67-0-tnbux with resources io.airbyte.config.ResourceRequirements@269e46ea[cpuRequest=,cpuLimit=,memoryRequest=,memoryLimit=,additionalProperties={}] and allowedHosts null
2024-03-07 11:08:12 platform &gt; Preparing command: docker run --rm --init -i -w /data/86a82371-6cf2-461a-9955-570e93244f67/0 --log-driver none --name source-declarative-manifest-discover-86a82371-6cf2-461a-9955-570e93244f67-0-tnbux --network host -v airbyte_workspace:/data -v /tmp/airbyte_local:/local -e DEPLOYMENT_MODE=OSS -e WORKER_CONNECTOR_IMAGE=airbyte/source-declarative-manifest:0.61.2 -e AUTO_DETECT_SCHEMA=true -e LAUNCHDARKLY_KEY= -e SOCAT_KUBE_CPU_REQUEST=0.1 -e SOCAT_KUBE_CPU_LIMIT=2.0 -e FIELD_SELECTION_WORKSPACES= -e USE_STREAM_CAPABLE_STATE=true -e WORKER_ENVIRONMENT=DOCKER -e AIRBYTE_ROLE=dev -e APPLY_FIELD_SELECTION=false -e WORKER_JOB_ATTEMPT=0 -e OTEL_COLLECTOR_ENDPOINT=<http://host.docker.internal:4317> -e FEATURE_FLAG_CLIENT=config -e AIRBYTE_VERSION=0.50.49 -e WORKER_JOB_ID=86a82371-6cf2-461a-9955-570e93244f67 airbyte/source-declarative-manifest:0.61.2 discover --config source_config.json
2024-03-07 11:08:12 platform &gt; Reading messages from protocol version 0.2.0```
If I try to refresh the schema of one of the connectors that has already been setup I get the following error:
`Internal Server Error: Cannot invoke "io.airbyte.api.model.generated.AirbyteCatalog.getStreams()" because "discovered" is null`

I have other custom connectors that works just fine. I have tried to create a new custom connector where I have set it up again via the UI, but I still get the same error

Has anybody faced this issue or have any idea what might be causing the issue?

manifest.yaml for the connector is attached



This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. [Click here]( if you want to access the original thread.

[Join the conversation on Slack](

["custom-low-code-connector", "webshipper", "builder", "discover-schema-failed", "internal-server-error", "manifest.yaml"]

<@U04SE163WC8> any thoughts on this?

I’m sorry, but your question is quite vague. Could you please provide more details or context? I’m here to provide information and answer questions about Airbyte, the open-source data integration engine.

<@U04SE163WC8> Why do I get the Discovering schema failed error?

A message from|

New message text here

The issue seem to come from the incremental settings. If I remove the incremental settings the discovery works.

The code works in airbyte cloud, but not on Airbyte OSS with v0.50.49, v0.50.54, or v0.53.1