Issues with API calls to Airbyte Cloud

Also, the Airflow task was working just fine, but started failing sporadically as ya’ll were rolling out changes:

Hi Chris, thanks for providing additional details, that really helps. I now thinks it has something to do with security policy configuration. Your request are getting rejected by the LB which is why I did not see anything on the server telemetry.
I’m looking further into it now

If that is possible, could you try setting the user agent to something custom for your client?

Is that done via a header option?

The weird thing is when I run the example curl command from your docs on my local machine it actually works

It’s just the Python one that doesn’t work

Yes it is a header “User-Agent”

Okay, yeah. This worked:

url = "<>"

payload = {
    "jobType": "sync",
    "connectionId": "9d23019a-d983-4802-829d-ba13c88ba68c"

headers = {
    "accept": "application/json",
    "content-type": "application/json",
    "authorization": "Bearer <redacted>",
    "user-agent": "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/96.0.4664.110 Safari/537.36"

response =, json=payload, headers=headers)

that was just the user-agent that co-pilot recommended

but I can’t easily pass a user-agent to the Airflow Operator, that’s all abstracted as part of the pip packaging

Thanks for confirming! We’re gonna work on fixing those security rules on our end but that is gonna take a bit more time. I do not think we’ll be able to fix that over the weekend.

I cannot pass a header to the Airflow Operator
(unless I make another open-source contribution) -<| I already did that for you guys this week> :smile:

probably makes more sense for you guys to fix it on your end because who knows who else this is impacting.

It definitely does, I just want to be careful when modifying those stuff. I’ll keep you posted on the resolution

Following up here in case anyone else was experiencing that issue. This is now resolved.