Issues with API calls to Airbyte Cloud


Users experiencing problems with making API calls to Airbyte Cloud


Is anyone else experiencing issues with API calls to Airbyte Cloud?

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["api", "airbyte-cloud", "issues"]

This isn’t even working on <|the docs page> for me:

     --url <> \
     --header 'accept: application/json' \
     --header 'authorization: Bearer <redacted>' \
     --header 'content-type: application/json' \
     --data '
  "jobType": "sync",
  "connectionId": "73a2b108-045c-4024-8f06-907b3e22e225"

Hey Chris, we’ve identified an issue on our end and are working on a fix

I’ve verified that I can make api calls to other endpoints no problem.

In the meantime, we are rolling back our latest change. Sorry about that

LOL, I’m just happy it’s you and not me :laughing:

<@U05TC5QNQHX> we rolled back and I just successfully tested a request, can you give yours another try?

<@U04DNBGKS2Y>, sorry for the late reply. Looks like our pipelines started successfully running again 3 hours ago

<@U04DNBGKS2Y>, funny enough, it’s actually failing again :laughing:

So it worked for the last three hours, but just barely failed like 2 minutes ago

Yeah I had a fix that seemed to be working locally but am seeing it struggle in production so am pulling it back again. Not sure exactly why yet but will report back shortly.

<@U04DNBGKS2Y>…it’s failing again

Maybe we shouldn’t use your cloud service :laughing: – we’re evaluating moving off of OSS right now.

Apologies for the disruptions, we’re in the middle of a fairly large server migration currently.

For the errors that you saw, the messages are misleading and we’re reworking those right now - I believe the reason you got a 500 returned on those calls is that the job in question had ceased running (either succeeded or was already canceled) and couldn’t be canceled. The unhelpful error message was actually already a bug in the original implementation of the server, but it is on our radar and we should have a fix out shortly.

It’s down again. Ya’ll should really consider updating your status page

<@U04DNBGKS2Y> any updates on this? We’re still unable to make api calls to sync our airbyte cloud connections

Hi Christopher, can you give more details on the issue you are experiencing? We are not seeing any major issue at this time, plenty of calls are going through on the API.


So the endpoint works just fine <|in your docs> when I enter my api token, the connection ID and click the Try It!

However, if I run the request from my local machine in Python (using the exact script from your docs):

url = "<>"

payload = {
    "jobType": "sync",
    "connectionId": "4475d627-4137-4755-9e55-0bed73380721"
headers = {
    "accept": "application/json",
    "content-type": "application/json",
    "authorization": "Bearer &lt;redacted&gt;"

response = <|>(url, json=payload, headers=headers)

I get the following error:
`<!doctype html>&lt;meta charset="utf-8"&gt;&lt;meta name=viewport content="width=device-width, initial-scale=1"&gt;&lt;title&gt;403&lt;/title&gt;403 Forbidden`

So it feels like if I try to run the request (with Python) anywhere besides your docs page, it gets rejected (which is weird, because it’s the same exact code)

We’re triggering this sync from Airflow, and I thought maybe my api token expired or something, but I tried it with a fresh API token locally and I got the same error