Memory Limit Issue with Docker Containers on EC2 Instance


The user is facing an issue where new source or destination Docker containers are launched with a 2GB memory limit after changing the EC2 instance size. The user has tried various solutions but none have worked.


Hi everyone, i have a problem with my opensource self hosted install, i installed the server using the docker compose, on an EC2 Instance. then i change the instance size to add more mem and cpu. but now i have a problem that every new source or destination docker is launched with 2Gb Mem limit.
and no matter what i try nothing helps.

anyone have any idea on this

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want
to access the original thread.

Join the conversation on Slack

["memory-limit", "docker-containers", "ec2-instance", "self-hosted", "docker-compose"]

You need to set this in your .env . . . the specific properties you’re looking for are:
Note that the requests are the starting values, and in some cases they can increase up to the limit. When you hit the CPU limit specified for that job, performance gets throttled. But if you hit the memory limit specified, the job container will be killed.

There are other requests/limits, but those are probably the most likely ones you care about.

Thanks for the answer, i did that, but didn’t know i had to recreate the docker compose every time i changed anything in the .env, i though reboot would be enough. now it works for me.