Missing data when connecting from Shopify to Big Query

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: Ubuntu 22.04 x64
  • Memory / Disk: 8Gb / 160 Gb
  • Deployment: Docker
  • Airbyte Version: 0.40.8
  • Source name/version: Shopify
  • Destination name/version: Big Query
  • Step: The issue is happening during sync
  • Description: We are getting data from shopify and sending it to Big Query. We are fetching orders data and transaction data from shopify account. Now the amount of total orders data fetched is 71,613 committed records. But total transaction data fetched is 11,134 committed records. But the number was supposed to be same. We fetched orders data and transaction data together and also separately, but the result is same. Transaction data’s are not getting fetched totally.

Can anyone help?

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

1 Like

Here’s the log file.

b84ff814_b15a_4db4_97ae_7ff8bd56a8c6_logs_10_txt.txt (6.0 MB)

I have uploaded the logs. Would you have a look, please?

Hey there, thanks for attaching the logs. I have been reviewing them and I’m still not sure exactly what is causing this, but I do see you are using BigQuery 1.21. Can you try upgrading and see if the issue persists? In the changelog that version is listed as bugged! https://docs.airbyte.com/integrations/destinations/bigquery#changelog