MS SQL Server to MYSQL = non-json response

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu
  • Memory / Disk: 32GB
  • Deployment: Docker Swarm
  • Airbyte Version: 0.45.25
  • Source name/version: Microsoft SQL Server (MSSQL) ver. 0.4.26
  • Destination name/version: MYSQL ver. 0.1.20
  • Step: While setting up the connection (Set up connection)
  • Description: I set up a MS SQL Server as Source (JTL Database) and a MYSQL as Destination (MYSQL 8.0.31) and tried to set these up as connection. As soon as a click on “Set up connection” i get the following error:


We use this MYSQL Service as destination for our Amazon Selling Partner data also, which works. (ASP → MYSQL)

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey @aschmidt, thanks for all the details! I know this could use better error logging and we’re working on it. Let me think on how best to debug this and I’ll get back to you!

Hey @aschmidt,
I am also using JTL as a Source but SQL Server as the destination.
It’s working fine for me with SQL Server 2019.

Did you try to use a different destination?

Hey @Benjamin, thanks for your reply.
I tried SQL Server 2019 but i still get the “non-json response” error.
Did you used a docker-compose? And which version of Airbyte do you use?

I just checked my proxy logs and found this line:

*2251 client intended to send too large body: 1737214 bytes, client:, 
server: , request: "POST /api/v1/web_backend/connections/create HTTP/1.1", host: 
referrer: ""

So i added “client_max_body_size 50M;” to my nginx.conf and restarted nginx manually.
But still the same error

Ok we needed to update to version 0.40.26 were this issue were fixed

Wonderful to hear that updating fixed this!