MySQL 1.0.1 and MySQL 1.0.6 Fails to handle separate streams

Full specs (see separate issue here MySQL 1.0.1 (GA) Source Normalization Failure)
Airbyte Version: 0.40.1
Source: MySQL (1.0.1)
Destination: Snowflake (0.4.38)

003203 (42601): Cannot drop column '_AIRBYTE_UNIQUE_KEY' which belongs to a clustering key

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey there, I’m trying to catch up on all the threads around these issues. Am I correct in my understanding that this issue is actively blocking you? Are you able to manually drop the tables and then reset/sync to get unblocked?

I have created a Github issue to track this:

Could you please attach complete logs from when this happened? Also, if v0.40.1 is not a typo, could you try with a newer version of Airbyte?

@sh4sh apologies but i cant afford to try this again as it was a nightmare to manually update the schema via the API (without having it overwritten each time i re-save the connector). its a huge production table and ive already wasted a bunch of time and money attempting to resync a bunch of times.

i would rather opt for reproducibility and establishing regression tests on airbyte’s end if possible. i dont think ive ever had an update of MySQL source without issues :slightly_frowning_face: and feel like it’s lacking the breadth of regression/backward-compatible tests (but i appreciate I’m not fully versed in the backend of the mysql source code)

1 Like

Understood. So sorry for your experience here :frowning: Can you create a request to improve regression testing on the mysql source connector, so we can make sure it is tracked?

I’m not sure where else to go with this ticket for the moment, my understanding is that dropping the column in the warning column '_AIRBYTE_UNIQUE_KEY' in the destination tables should unblock the sync, but you would likely need to reset/sync to get it going again. Is there anything I can look into for you here, or should we wait to see about improvements?

I’ve just tried this again on a clean connector
airbyte version 0.40.14

  • I create a new connection.
  • I sync one table
  • I sync again to confirm CDC and its working correctly.
  • I refresh schema and add another table
  • I reset the connection and it correctly “resets” affected tables (it shouldn’t really do this as it hasn’t actually brought in the table yet) but positively, it doesn’t reset the existing table
  • The reset fails

2022-10-21 04:59:55 - Additional Failure Information: 003203 (42601): Cannot drop column '_AIRBYTE_UNIQUE_KEY' which belongs to a clustering key