Sharing DATABASE_URL, DATABASE_PASSWORD in application.yml for config and jobs datasource in Airbyte-bootloader

Summary

The user is questioning if sharing the DATABASE_URL and DATABASE_PASSWORD in the application.yml for both config and jobs datasource in Airbyte-bootloader forces the tables for job and config databases to be created in the same database, despite separate configurations for username, password, and URL for the config database.


Question

Hi,
In application.yml from airbyte-bootloader I noticed that config and jobs datasource configuration share the same DATABASE_URL, DATABASE_PASSWORD, DATABASE_URL.

  config:
    connection-test-query: SELECT 1
    connection-timeout: 30000
    idle-timeout: 600000
    initialization-fail-timeout: -1 # Disable fail fast checking to avoid issues due to other pods not being started in time
    maximum-pool-size: 5
    minimum-idle: 0
    url: ${DATABASE_URL}
    driverClassName: org.postgresql.Driver
    username: ${DATABASE_USER}
    password: ${DATABASE_PASSWORD}
  jobs:
    connection-test-query: SELECT 1
    connection-timeout: 30000
    idle-timeout: 600000
    initialization-fail-timeout: -1 # Disable fail fast checking to avoid issues due to other pods not being started in time
    maximum-pool-size: 5
    minimum-idle: 0
    url: ${DATABASE_URL}
    driverClassName: org.postgresql.Driver
    username: ${DATABASE_USER}
    password: ${DATABASE_PASSWORD}```
Doesn't this force tables for job and config database be created in same database even though separate username, password, and url for config database is configured?

<br>

---

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. [Click here](https://airbytehq.slack.com/archives/C021JANJ6TY/p1708653440631379) if you want to access the original thread.

[Join the conversation on Slack](https://slack.airbyte.com)

<sub>
["airbyte-bootloader", "application.yml", "config", "jobs", "datasource", "database-url", "database-password", "postgresql-driver"]
</sub>