Source Posgres Connector error starting in 1.0.43

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu
  • Memory / Disk: 4Gb / 1 Tb
  • Deployment: Kubernetes
  • Airbyte Version: 0.41.0
  • Source name/version: Postgres 1.0.45
  • Destination name/version: GCS 0.2.14
  • Step: Sync
  • Description:

When I update my Postgres connector from 1.0.42 to 1.0.43 the sync is failing with this error

tech.allegro.schema.json2avro.converter.AvroConversionException: Failed to convert JSON to Avro: Could not evaluate union, field <field> is expected to be one of these: NULL, ARRAY

Do you have any idea?

Thanks a lot

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey @lucienfregosi

Thanks for the post. Can you upgrade to 1.0.49 and re-rerun the sync? Or have you already done this? Are there any logs you can share of the run that is currently failing?

It might help to identify the field that is causing the problem and ensure that its value in the JSON data matches one of the expected types in the Avro schema.

I tried in 1.0.49 and even 2.0.0

I can attach the log.
The thing is that it doesn’t seem related to the data itself as it works perfectly in 1.0.42.

Any update @sajarin ?