Source setup failed: Unable to connect to stream

Hi, I’m trying to build a custom source connector with low-code connector development, but stuck at Step 3: Connecting to the API
The error is:

{“type”: “LOG”, “log”: {“level”: “ERROR”, “message”: “Check failed”}}
{“type”: “CONNECTION_STATUS”, “connectionStatus”: {“status”: “FAILED”, “message”: “‘Unable to connect to stream list all requests - Expecting value: line 1 column 1 (char 0)’”}}

My source API is very simple. It requires only some parameters such as:

  • Access token
  • Created_from:
  • Creared_to:

The docs of my source API is: Request Public API (section List all requests in system)

Here is my yaml:

version: “0.1.0”
url_base: “
http_method: “POST”
access_token: “{{ config[‘access_token’] }}”
status: “{{ config[‘status’] }}”
created_from: “{{ config[‘created_from’] }}”
created_to: “{{ config[‘created_to’] }}”
$ref: “*ref(definitions.selector)”
type: NoPagination
$ref: “*ref(definitions.requester)”
$ref: “*ref(definitions.retriever)”
$ref: “*ref(definitions.base_stream)”
name: “list all requests”
primary_key: “id”
path: “/extapi/v1/request/list”
streams: - “*ref(definitions.list_all_requests_stream)”
- “list all requests”

Python spec work fined

{“type”: “SPEC”, “spec”: {“documentationUrl”: “Request Public API”, “connectionSpecification”: {“$schema”: “”, “title”: “Basevn Request Spec”, “type”: “object”, “required”: [“access_token”, “status”, “created_from”, “created_to”], “additionalProperties”: true, “properties”: {“access_token”: {“type”: “string”, “description”: “request access token provided by Basevn, unique for each system”}, “status”: {“type”: “string”, “description”: “status value such as pending, approved, rejected, overdue”}, “created_from”: {“type”: “string”, “description”: “date request created”, “pattern”: “[0-9]{2}/[0-9]{2}/[0-9]{4}$”, “examples”: [“dd/mm/YYYY”]}, “created_to”: {“type”: “string”, “description”: “date request created”, “pattern”: “[0-9]{2}/[0-9]{2}/[0-9]{4}$”, “examples”: [“dd/mm/YYYY”]}}}}}

Hope someone can help

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hi, I’m getting the same error when I try following the exchange rate api tutorial. Are you using ubuntu?

Hi, @Alcadeus0
I use Windown, I guess this is Alpha version, so there might some bugs.

Are you still having issues Phuc?