Sync problem with Airbyte instance version 0.63.4


Facing sync issue with Airbyte instance version 0.63.4


Hello everyone,
I am facing a sync problem with my Airbyte instance (version 0.63.4). I am getting the following error message:

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want
to access the original thread.

Join the conversation on Slack

["sync-problem", "airbyte-instance", "version-0.63.4", "error-message"]

Sync Failed
0 Bytes
No records extracted
No records loaded
1m 15s
Error in destination: “You must upgrade your platform version to use this connector version. Either downgrade your connector or upgrade platform to 0.63.0.”
Has anyone encountered this issue before or know how I can resolve it?
Thank you in advance for your help!

Which connectors are in this sync?

Facing the same problem

has anyone been able to solve this problem?
any golden tips?

Hello <@U077NJ0FVQC> and <@U07BB9G9CVC>,
I believe this is related to|this issue. You will need to do a manual operation similar to|this one. We went with a manual fix while we are working on a more long term fix which is being worked on currently. I believe that you upgrade the version of the BQ connector before upgrading the platform.

Could you let me know which destination you are using as well as their version so I can help you with the update query.

Thank you <@U02TNBN74BU> for your reply. I’m using BigQuery v2.8.1 on Airbyte v0.63.0

I’ve tried your approach but unfortunately didn’t succeed, still facing the same error: Failure in destination: You must upgrade your platform version to use this connector version. Either downgrade your connector or upgrade platform to 0.63.0

 supports_refreshes | docker_image_tag 
 t                  | 2.1.3
 t                  | 2.8.1
 t                  | 2.3.31
 t                  | 2.8.0
 t                  | 2.4.10
 t                  | 2.5.1
 t                  | 2.4.2
 t                  | 2.4.12
 t                  | 2.7.0
 t                  | 1.4.3
 t                  | 2.6.3```

This is not related to you issue but the refreshes functionality has been released with version 2.7.0 of big query. So all the entries with a lower version should have false in the refreshes column.
About the failure could you confirm that the failing job is a new job and not just a new attempt.

Ok, I’ve updated the table accordingly but still not working. I’m trying to set up a new destination but even this task won’t succeed. I’ve also updated BigQuery connector to v2.8.2 without success. What else can I do?

My source is MySqlv3.4.12. When setting up a new connection, I’m facing Discovering schema failed error, so it may be a problem related to source as well?

Also with a Community Source (ZohoCRM) I’m facing problems

 airbyte/destination-bigquery | 2.8.2            | t
 airbyte/destination-bigquery | 2.8.1            | t
 airbyte/destination-bigquery | 2.8.0            | t
 airbyte/destination-bigquery | 2.7.0            | t
 airbyte/destination-bigquery | 2.6.3            | f
 airbyte/destination-bigquery | 2.6.1            | f
 airbyte/destination-bigquery | 2.5.1            | f
 airbyte/destination-bigquery | 2.4.2            | f
 airbyte/destination-bigquery | 2.4.12           | f
 airbyte/destination-bigquery | 2.4.10           | f
 airbyte/destination-bigquery | 2.3.31           | f
 airbyte/destination-bigquery | 2.1.3            | f
 airbyte/destination-bigquery | 1.4.3            | f```