Too much RAM usage, huge log files

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: 20.04
  • Memory / Disk: 64GB/8TB
  • Deployment: Docker compose
  • Airbyte Version: 0.40.4
  • Source name/version: postgres/1.0.7
  • Destination name/version: clickhouse/0.1.12
  • Step: during sync
  • Description:

For context, I am trying to sync a table with 500m rows from Postgres to clickhouse.

Having too many issues in Airbyte

  • RAM - Postgres source was taking up too much RAM (76%), causing other programs to stop. Then the connection itself failed. Several (>100) /usr/local/openjdk-19/bin/java -XX:+ExitOnOutOfMemoryError -XX:MaxRAMPercentage=75.0 processes running. Some of them taking a huge amount of RAM (>50%).
  • Log files - Log files as large as 80GB. Several of them are 20+ GB.
  • Job failing with Schema validation errors found for stream my_table. Error messages: [$.rank is of an incorrect type. Expected it to be number] when it used to run before.

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Please update to latest version: fixed the issue.

Hi @marcosmarxm the other issues do remain - especially several threads of /usr/local/openjdk-19/bin/java -XX:+ExitOnOutOfMemoryError -XX:MaxRAMPercentage=75.0

One of those threads is at 46% of the memory

Hey do you mind killing them up and retry the sync with latest version

Hi, the screenshot was taken after I had upgraded the Airbyte version to 0.40.06 and Postgres connector to 1.0.9.

I have tried killing them, I have also tried restarting airbyte, I have also restarted the server but the problem still appears after sometime

Hey got it. Could you create a github issue with the information so that team can look at it and get back to you