Unable to connect to Airbyte on Google Cloud Platform

Summary

Unable to connect to Airbyte on Google Cloud Platform due to HTTP Error Code 401. Issue related to HTTP Basic Authentication.


Question

Hi all,
I have set up airbyte on the Google Cloud Platform by using the given https://docs.airbyte.com/deploying-airbyte/on-gcp-compute-engine|documentation and I am not getting any error in any of the steps. unfortunately, I am not able to connect to the localhost:8000. when I run the “curl localhost:8000” comment, See the response that I am getting. It would be great if anyone can help me to connect the CGP VM from my local host using SSH.

  <head>
    <meta charset="utf-8" />
    <title>Airbyte - Access Denied</title>
  </head>
  <body>
    <h1>🐙 Nope.</h1>
    <h2><code>HTTP Error Code: 401</code></h2>

    <p>
      This deployment of Airbyte is protected by HTTP Basic Authentication.
      Please refer to the &lt;a href="<https://docs.airbyte.com>"&gt;Airbyte docs&lt;/a&gt; to learn more about:
      &lt;ul&gt;
	      &lt;li&gt;&lt;a href="<https://docs.airbyte.com/quickstart/deploy-airbyte>"&gt;the default username/password&lt;/a&gt;&lt;/li&gt;
	      &lt;li&gt;&lt;a href="<https://docs.airbyte.com/operator-guides/security>"&gt;securing your Airbyte deployment&lt;/a&gt; including turning off or changing the default username/password.&lt;/li&gt;
      &lt;/ul&gt;
    &lt;/p&gt;
  &lt;/body&gt;
&lt;/html&gt;```

<br>

---

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. [Click here](https://airbytehq.slack.com/archives/C021JANJ6TY/p1709755653240899) if you want to access the original thread.

[Join the conversation on Slack](https://slack.airbyte.com)

<sub>
["google-cloud-platform", "airbyte", "http-error-401", "http-basic-authentication"]
</sub>

Your Airbyte webserver is not in your local machine, but in your GCP tenancy/project. So you need an ssh tunnel to bring whatever is in port 8000 in the GCP VM to your local machine (your laptop).

gcloud compute ssh &lt;your-vm-name&gt; --project=&lt;your-project-name&gt; --zone=&lt;your-gcp-zone&gt; -- L 8000:localhost:8000 -N -f
Run this in your terminal and then try to connect again with your browser. It make take a minute. You’ll get the basic auth dialog.

<@U06AR3ZJY4T> Thanks for the reply. I have run the same command it runs perfectly not getting any error. See the attached screenshot, I am getting the same response in my local browser.

Bang! Just open your browser at localhost:8000

<@U06AR3ZJY4T> Thanks for the reply. yes, that is the issue not able to connect on localhost:8000. showing the same screen that I have earlier sent.
This site can't be reached localhost refused to connect.

Try 127.0.0.1:8000 or 0.0.0.0:8000?

It may be your computer doesn’t recognise localhost as itself. DNS problem.

Not related to Airbyte, as it seems.

Thanks, <@U06AR3ZJY4T> for the quick response. I have checked this one unfortunately it’s not working. Maybe it’s a port issue.

Hey <@U06AR3ZJY4T> I tried same on fresh macOS system. gcloud compute ssh command works without any error. but when trying localhost:8000 or 127.0.0.1:8000, it doesn’t work. I’m not running any docker container in my computer nor any service is using this port or localhost.

Any way to debug this? it’s possible many users might be facing this issue. this thread would help them. Thanks

I’m not working for Airbyte, I just thought it could be something I could help you with. Sorry, mate. Good luck!

Thanks <@U06AR3ZJY4T> appreciate your assistance

<@U052V9X8R88> Could you help here please? we have just followed same instructions and at the last strep, localhost:8000 doesn’t work without any error.