Using Terraform with Airbyte in Local Machine


When using Terraform to define sources, destinations, and connections in a local machine with Airbyte, encountering a TLS certificate verification error when sending a request to the API port 61662. The error message indicates a certificate trust issue with the ‘kube-apiserver’ certificate.


Hi! I’m testing terraform to define sources, destinations and connections in my local machine. I started airbyte using the abctl install which launches a kind cluster in docker. The API port is 61662 and when i do the terraform apply i get:
error sending request: Post "<https://localhost:61662/v1/sources>": tls: failed to verify certificate: x509: "kube-apiserver" certificate is not trusted
Anyone has been able to use terraform in local with this setup? Thanks lots

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want
to access the original thread.

Join the conversation on Slack

["terraform", "airbyte", "local-machine", "tls-certificate", "kube-apiserver"]

wouldn’t be easier to use http and default port 8000?

If i change to http and port 8000 i get the following error:
> unknown status code returned: Status 405
> │ <html>
> │ <head><title>405 Not Allowed</title></head>
> │ <body>
> │ <center><h1>405 Not Allowed</h1></center>
> │ <hr><center>nginx/1.25.4</center>
> │ </body>
> │ </html>

Have you tried to set server_url like this?

  server_url = "<http://localhost:8000/api/public/v1>"

yup, seems that it worked! thanks!

Context on this change:

TLDR; everything should talk to the server as they’re deprecating the stand-alone api-server