WooCommerce - Not authorizing for API url during sync

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu
  • Memory / Disk: 4Gb / 30GB
  • Deployment: Google Cloud Compute
  • Airbyte Version: What version are you using now? 0.40.10
  • Source name/version: WooCommerce / 0.1.1
  • Destination name/version: BigQuery / 1.2.4
  • Step: The issue is happening during sync
  • Description: Airbyte was also able to connect during the initial setup of the connector, but throwing an error for “Unauthorized for url” during the sync. I am able to manually connect via the browser or through Postman using the same method (Basic Auth). All credentials provided are confirmed to be correct. Based on the error, it looks like the customer_key and customer_secret values are not passed into the URL in any way, which would explain why the response would show a lack of permissions. When I use the same url as Airbyte but add in those 2 attributes, it can successfully connect and return results. This seems to indicate that the API credentials and setup on the WooCommerce side are fine, but something is off with how Airbyte is trying to pass these values during the sync. I’ve attached a screenshot of the error and a copy of the logs for reference. Is this a known issue or is there an extra step that I am missing to properly allow this to connect?
    12dbcf62_bf38_40be_8df2_287441f1b9c3_logs_14_txt.txt (124.8 KB)

Thank you!

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

"internalMessage" : "401 Client Error: Unauthorized for url: https://www.ilnp.com/wp-json/wc/v3/customers?per_page=100&after=2022-01-01T00%3A00%3A00&before=2022-10-10T14%3A21%3A17.512416&orderby=registered_date&order=asc", "externalMessage" : "Sorry, you cannot list resources.",

Hey could you check if the required permissions are given

Hi - As mentioned in the original post, I get the same error when using this link directly. But it does work when I pass the customer key & secret - which is what I also configured in Airbyte.

Got it. Can you create a github issue around this so that team can get back to you

Thanks for the help. We ended up using the MySQL connector to go direct to the DB instead of WooCommerce and it works.