0.40.7 Worker Micronaut Update Causing Worker to Constantly Crash

  • Is this your first time deploying Airbyte: No
  • OS Version / Instance: EC2 t2.large
  • Memory / Disk: 16Gb
  • Deployment: Docker
  • Airbyte Version: 0.40.7
  • Description:
    A few days ago our Postgres connector started to fail, we were running 0.4.40 and so we upgraded to 1.0.10 and subsequently upgraded from Airbyte 0.40.0-alpha to 0.40.7. After these two upgrades one of our Postgres runs simply says running and there are no logs and we cannot cancel this run no matter what we do: restart docker, reboot docker, kill all containers, restart the machine, etc. What I noticed:
  1. was that when we run docker ps the worker keeps restarting. See first image below.
  2. everything is frozen. I cannot refresh the schema for any of my connections they are forever stuck on please wait. Even for connections with only 1 table and 200 rows. see second image
  3. sync is forever running and cannot cancel. see image 3

Any help is apprecaited, it has been going on for days.

Running docker logs airbyte-worker reveals this error:

2022-09-19 20:44:51 ERROR i.m.r.Micronaut(handleStartupException):338 - Error starting Micronaut server: Failed to inject value for parameter [dslContext] of method [configDatabase] of class: io.airbyte.db.Database

We are downgrading to 0.40.6 before the Micronaut update to see if this resolves the issue

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

There was an issue with my docker-compose and .env file, updating that resolved the issue

@kyle-cheung Would you mind telling us what the issues were? I have exactly the same error after upgrading to 0.40.7, but I can’t find the mistake on my side…
(Maybe to add: I’m using the k8s manifests provided by airbyte, not docker-compose. But still the error is the same, so I guess it’s somehow related)

Basically our docker-compose and .env file was missing a ton of config lines including the micronaut ones. Our Airbyte instance is managed by Terraform, so when we upgraded our Airbyte to version 0.40.7 we had forgotten to update the contents of the underlying files that contained new lines of code for the Micronaut configs that 0.40.7 uses

Not sure if that helps.

1 Like

Great to hear you were able to resolve your issue! The team was at an offsite last week and our response time was slower than usual. Please feel free to reach out on the forum or slack and we’ll be happy to help with any further questions! :slight_smile: