413 Request Entity Too Large nginx/1.23.2

Hi, this is my team’s first time deploying Airbyte. We’ve deployed airbyte on an AWS EC2 instance according to the instructions in this guide: On AWS (EC2) - Airbyte Documentation. Some information regarding the instance

  • OS is Amazon Linux 2
  • Instance is a t2.large with 2 vCPUs and 64 GBs
  • Deployment using Docker

When trying to set up a connection from salesforce to snowflake, I’m getting the error 413 Request Entity Too Large nginx/1.23.2. I’ve read up a bit and it seems this can be solved by updating the nginx config file and then rebuilding the docker container airbyte-proxy. I don’t have much experience with docker. My main questions are where do I find the nginx config file used by docker in the airbyte-proxy container, how do I update it so that it’s new configurations are used regardless by how many times I deploy the container and how do I redploy the container after updating the nginx file?

Any support in this regard would be great.

This is the directory structer of where airbyte is.

└── airbyte
├── docker_boot.service
├── docker-compose.yaml
└── temporal
└── dynamicconfig

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
Best,
The Community Assistance Team