Airbyte error on startup with docker-compose

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu Server 22.04
  • Memory / Disk: 8Gb / 80GB
  • Deployment: docker-compose
  • Airbyte Version: 0.40.26
  • Source name/version: -
  • Destination name/version: -
  • Step: Error occurs during the startup with docker-compose up on a fresh install

I can’t get airbyte to run on a fresh install of ubuntu 22.04. The only things I have done was configure ssh and install docker & docker compose. After running docker-compose up, airbyte seems to be stuck in a loop with the error repeating. From reading through the error messages, I think it may have to do something with the PostgreSQL DB.

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

The snap version of docker was installed, which caused the problem. It worked with the apt docker version. Ubuntu seems to always prefer the snap version, no matter what other docker versions are installed.
Completely remove the snap version and it fixes the problem :slight_smile:

Hey @julian, so glad to hear this is resolved! Good to know about the docker versions :slight_smile: