Cannot run Airbyte locally - Bootloader cannot complete upgrade from fresh git clone

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: MacOS Monterey 12.6 , M1 Chip
  • Memory / Disk: 8GB / 0.5TB
  • Deployment: Docker
  • Airbyte Version: 0.40.26
  • Source name/version: None
  • Destination name/version: None
  • Step: Server Start Up
  • Description: Cannot run Airbyte locally, it looks like the server cannot start up. I started from a fresh git clone and simply run docker compose up. Images downloaded just fine but when starting two issues occured that might be intertwined
  1. Bootloader app doesn’t launch :
    Cannot upgrade from version 0.30.22-alpha to version 0.40.26 directly. First you must upgrade to version 0.32.0-alpha. After that upgrade is complete, you may upgrade to version 0.40.26
    I reckon this is due to airbyte version bumps, but I’m starting from a fresh install here so not sure what to do.

  2. Server app crashes :
    Timeout while waiting for database to fulfill minimum flyway migration version..
    The server app crashes in loop because it seems it cannot reach the database app

I’m not sure my diagnostic is correct :
Full logs here linked
logs.txt (160.1 KB)

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hello there.

Before installing from the fresh git clone, did you delete the existing containers that were created from the previous installation?

Looking at this error seems like this is the case:

Unable to create SQL database. {“error”: "pq: database "temporal" already exists

Can you try to run docker compose ps -a inside the directory where your yaml file is? This will print the (possibly) existing containers and you will be able to sort it out by probably deleting them.

Best regards.

Hey @JohnGreek Thanks a lot for looking into it :pray: .
So i’ve cleaned my docker images and started over. It’s now fixed !

You are very welcome! Glad I could help :slightly_smiling_face:
Also please mark the issue as solved so it’s more visible to others who may find this post and need similar help.