Airtable source connector - OAuth authentication problem

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu
  • Memory / Disk: 12 GBs / 30 GBs
  • Deployment: Docker
  • Airbyte Version: 0.40.26
  • Source name/version: Airtable/2.0.3
  • Destination name/version: Bigquery/1.2.14
  • Step: During sync
  • Description: I’ve tried to change the authentication to Airtable by using the OAuth, and it does work for two hours, but then I get a message
2023-03-02 09:30:15 source > {"error":{"type":"UNAUTHORIZED","message":"Invalid authentication token"}}
2023-03-02 09:30:15 source > 401 Client Error: Unauthorized for url:

This happened twice already, same pattern: I create a new refresh token, save the connection and execute it hourly, it works for two hours, and from the third hour on I receive this error message.

Furthermore, on the first time this happened, I’ve got this email

But this didn’t happen in the second time. I’ve tried to go to the Integration’s panel, but nothing changed there

Now, I don’t know if the problem is with Airbyte, and how this integration is being called, or with Airtable.

The steps I’ve followed to create the refresh-token:
1- On Airtable, created a new OAuth integration called “Airbyte”
2- Added the following scopes data.records:read, data.recordComments:read and schema.bases:read
3- Executed this GET request to get the code using the client_id generated by the OAuth integration Airtable Web API
4- With the code received from the GET request above, executed a POST request as such Airtable Web API

With the information received from the POST request, added the following information in the Airbyte connector:

  • Client ID
  • access_token
  • Client secret
  • Refresh token
  • token_expiry_date (this one, I’ve chosen as “2 months”)

Full log uploaded
12cde809_e760_4c5e_93f9_16e8776afd71_logs_15506_txt.txt (146.8 KB)

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Got the same issue!
I went back to 0.1.3 just because of that - the API Token version there works fine. But OAuth has to be fixed. Bumping this one up in hope someone will have an idea how to work around the issue. :wink: