AWS ALB 403 error when saving connection in Airbyte UI from EKS


User is facing a 403 error when trying to save a connection in Airbyte UI deployed behind an AWS ALB from EKS. The issue seems to be related to authentication when communicating with the API server. User is unsure if the API needs to be added to the path routing and is seeking clarification on the root path.


I am deploying airbyte behind an AWS ALB from EKS. I can get to the UI just fine over the ALB, but any time i attempt to save a connection, i get a lovely 403. When i do it via a port forward the same connection works just fine from what i can tell. So i’m assuming there is something auth related that is having issues communicating with the api server. Most of the settings on the ALB like preservation of client port, x-forward-for headers, preserving host headers, etc are all enabled. Routing is /* and a http://HOSTNAME.DOMAIN.COM|HOSTNAME.DOMAIN.COM (so i can’t imagine I’m missing requests). My understanding of the architecture was that just the webapp needed to be exposed. Do I also need to add the api into the path routing? If so, what is the root path?

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["aws-alb", "eks", "airbyte-ui", "403-error", "authentication", "api-server", "path-routing", "root-path"]

Whats interesting is that i can turn off a connection made from localhost at and get a 200, but if i try to adjust the connection and save it (or create a new one), i get a 403 at that very same endpoint.