Configuration export->import not working

  • Is this your first time deploying Airbyte: No
  • OS Version / Instance: Ubuntu 20.04
  • Memory / Disk: 8Gb / 200GB SSD
  • Deployment: Docker
  • Airbyte Version: 0.35.65-alpha
  • Step: Moving to a new airbyte installation. Importing configuration fails
  • Description: When I export my configuration I get a .gz file. Then I go to my new install and try to upload the config file. This config upload does nothing. When I try to upload the file using the API I get the following error:
  "status": "failed",
  "reason": "io.airbyte.validation.json.JsonValidationException: json schema validation failed when comparing the data to the json schema. \nErrors: $.catalog: null found, object expected \nSchema: \n{\n  \"$schema\" : \"\",\n  \"$id\" : \"\",\n  \"title\" : \"ActorCatalog\",\n  \"description\" : \"Catalog of an actor.\",\n  \"type\" : \"object\",\n  \"additionalProperties\" : false,\n  \"required\" : [ \"id\", \"catalog\", \"catalogHash\" ],\n  \"properties\" : {\n    \"id\" : {\n      \"type\" : \"string\",\n      \"format\" : \"uuid\"\n    },\n    \"catalog\" : {\n      \"type\" : \"object\",\n      \"existingJavaType\" : \"com.fasterxml.jackson.databind.JsonNode\"\n    },\n    \"catalogHash\" : {\n      \"type\" : \"string\"\n    }\n  }\n}"

Any idea how I can work around this? Thanks.

What source and destination are you using?

I came across same issue. I exported the configuration and tried to import it to a new setup of a team member but nothing happened.

I am using 5xMYSQL connectors, the My Hours connector, Some Google Analytics, Google Ads, Bing Ads, Asana, Google directory, Salesforce and three small custom connectors. How can I see the schema that’s being checked for this? Maybe I can see what is missing.

I found using to import the configuration got me some more error details

Any info on this, or help on how I can debug this? Or is there another way to replicate my Airbyte installation to another system? I am using the default docker installation on a VPS.

Looks like someone on github has the same issue with a fresh install Import configuration fails · Issue #12012 · airbytehq/airbyte · GitHub

This is happening to us also, the problem resides in new version 0.35.67-alpha not taking EXPOSE_SECRETS_IN_EXPORT=true flag in consideration and exporting the config with password: "**********" from in both SOURCE_CONNECTION.yaml and DESTINATION_CONNECTION.yaml.

1 Like

I was able to import/export in 0.36.6-alpha after enable the variable EXPOSE_SECRETS_IN_EXPROT=true. Can you check again Wise?

After setting this to true and restarting the docker images it’s still not working. Although I don’t have the json validation schema anymore. This is the error I am getting now:

Raise issue to our platform team to solve issue.

1 Like

Hi there from the Community Assistance team.
We’re letting you know about an issue we discovered with the back-end process we use to handle topics and responses on the forum. If you experienced a situation where you posted the last message in a topic that did not receive any further replies, please open a new topic to continue the discussion. In addition, if you’re having a problem and find a closed topic on the subject, go ahead and open a new topic on it and we’ll follow up with you. We apologize for the inconvenience, and appreciate your willingness to work with us to provide a supportive community.