Edit/create Google Ads source Connection Test Fails but No Error

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu
  • Memory / Disk: you can use something like 4Gb / 1 Tb
  • Deployment: Docker
  • Airbyte Version: Open source 0.40.22
  • Source name/version: Google ads 0.2.5
  • Destination name/version: Redshift 0.3.52
  • Step: editing or creating a new Google Ads source
  • Description: Remove this with the description of your problem.

I’m trying to edit (or create new) Google Ads source, the connection test fails for no obvious reason. Even if I only modify the name of the source it fails. The inputs are all correct as there is a connection already running daily with this source and with no error. I retried many times, for one of our multiple Google Ads sources retrying helped and it ended out working, but here it’s not the case…

Can anyone help identifying the issue ?

Here are the logs:

Configuration check failed
2:52PM 05/19 2023-01-04 15:28:08 INFO i.a.w.t.TemporalAttemptExecution(get):136 - Docker volume job log path: /tmp/workspace/dfcd0a0e-9235-492b-abf5-e34228546a8b/0/logs.log
2023-01-04 15:28:08 INFO i.a.w.t.TemporalAttemptExecution(get):141 - Executing worker wrapper. Airbyte version: 0.40.26
2023-01-04 15:28:08 INFO i.a.a.c.AirbyteApiClient(retryWithJitter):172 - Attempt 0 to save workflow id for cancellation
2023-01-04 15:28:08 INFO i.a.c.i.LineGobbler(voidCall):114 -
2023-01-04 15:28:08 INFO i.a.c.i.LineGobbler(voidCall):114 - ----- START CHECK -----
2023-01-04 15:28:08 INFO i.a.c.i.LineGobbler(voidCall):114 -
2023-01-04 15:28:08 INFO i.a.c.i.LineGobbler(voidCall):114 - Checking if airbyte/source-google-ads:0.2.5 exists…
2023-01-04 15:28:08 INFO i.a.c.i.LineGobbler(voidCall):114 - airbyte/source-google-ads:0.2.5 was found locally.
2023-01-04 15:28:08 INFO i.a.w.p.DockerProcessFactory(create):120 - Creating docker container = source-google-ads-check-dfcd0a0e-9235-492b-abf5-e34228546a8b-0-egocp with resources io.airbyte.config.ResourceRequirements@7b875f54[cpuRequest=,cpuLimit=,memoryRequest=,memoryLimit=]
2023-01-04 15:28:08 INFO i.a.w.p.DockerProcessFactory(create):164 - Preparing command: docker run --rm --init -i -w /data/dfcd0a0e-9235-492b-abf5-e34228546a8b/0 --log-driver none --name source-google-ads-check-dfcd0a0e-9235-492b-abf5-e34228546a8b-0-egocp --network host -v airbyte_workspace:/data -v /tmp/airbyte_local:/local -e DEPLOYMENT_MODE=OSS -e USE_STREAM_CAPABLE_STATE=true -e AIRBYTE_ROLE= -e WORKER_ENVIRONMENT=DOCKER -e WORKER_JOB_ATTEMPT=0 -e WORKER_CONNECTOR_IMAGE=airbyte/source-google-ads:0.2.5 -e AUTO_DETECT_SCHEMA=false -e AIRBYTE_VERSION=0.40.26 -e WORKER_JOB_ID=dfcd0a0e-9235-492b-abf5-e34228546a8b airbyte/source-google-ads:0.2.5 check --config source_config.json
2023-01-04 15:28:08 INFO i.a.w.i.VersionedAirbyteStreamFactory(create):97 - Reading messages from protocol version 0.2.0
2023-01-04 15:28:09 INFO i.a.w.i.DefaultAirbyteStreamFactory(internalLog):120 - Checking the config

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

It got solved on it’s own after many many retries.
Would still be interesting to understand why this bug happened