Source Google Search Console: Check connection failed

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: e2-medium VM with ubuntu-1804-bionic-v20220712
  • Deployment: Docker
  • Airbyte Version: 0.39.42-alpha
  • Source name/version: Google Search Console 0.1.13
  • Step: The issue is happening during creating a new source.
  • Description: After filling in the configuration form for Authentication Type ‘Service Account’ and setting up the source, there is an error: Check Connection Failed! Here are the logs:
2022-09-06 14:33:19 INFO i.a.w.t.TemporalAttemptExecution(get):105 - Docker volume job log path: /tmp/workspace/9500c841-0fe6-4da8-9f55-4ff042192548/0/logs.log
2022-09-06 14:33:19 INFO i.a.w.t.TemporalAttemptExecution(get):110 - Executing worker wrapper. Airbyte version: 0.39.42-alpha
2022-09-06 14:33:19 INFO i.a.c.i.LineGobbler(voidCall):82 - Checking if airbyte/source-google-search-console:0.1.13 exists...
2022-09-06 14:33:19 INFO i.a.c.i.LineGobbler(voidCall):82 - airbyte/source-google-search-console:0.1.13 was found locally.
2022-09-06 14:33:19 INFO i.a.w.p.DockerProcessFactory(create):108 - Creating docker job ID: 9500c841-0fe6-4da8-9f55-4ff042192548
2022-09-06 14:33:19 INFO i.a.w.p.DockerProcessFactory(create):163 - Preparing command: docker run --rm --init -i -w /data/9500c841-0fe6-4da8-9f55-4ff042192548/0 --log-driver none --name source-google-search-console-check-9500c841-0fe6-4da8-9f55-4ff042192548-0-qkhxx --network host -v airbyte_workspace:/data -v /tmp/airbyte_local:/local -e DEPLOYMENT_MODE=OSS -e USE_STREAM_CAPABLE_STATE=false -e WORKER_ENVIRONMENT=DOCKER -e AIRBYTE_ROLE= -e WORKER_CONNECTOR_IMAGE=airbyte/source-google-search-console:0.1.13 -e WORKER_JOB_ATTEMPT=0 -e AIRBYTE_VERSION=0.39.42-alpha -e WORKER_JOB_ID=9500c841-0fe6-4da8-9f55-4ff042192548 airbyte/source-google-search-console:0.1.13 check --config source_config.json
2022-09-06 14:33:19 ERROR i.a.w.i.DefaultAirbyteStreamFactory(internalLog):95 - Config validation error: '' does not match '^[0-9]{4}-[0-9]{2}-[0-9]{2}$'
Traceback (most recent call last):
  File "/airbyte/integration_code/", line 13, in <module>
    launch(source, sys.argv[1:])
  File "/usr/local/lib/python3.9/site-packages/airbyte_cdk/", line 123, in launch
    for message in
  File "/usr/local/lib/python3.9/site-packages/airbyte_cdk/", line 96, in run
    check_config_against_spec_or_exit(connector_config, source_spec)
  File "/usr/local/lib/python3.9/site-packages/airbyte_cdk/sources/utils/", line 160, in check_config_against_spec_or_exit
    raise Exception("Config validation error: " + validation_error.message) from None
Exception: Config validation error: '' does not match '^[0-9]{4}-[0-9]{2}-[0-9]{2}$'
2022-09-06 14:33:19 ERROR i.a.w.g.DefaultCheckConnectionWorker(run):94 - Error checking connection, status: Optional.empty, exit code: 1
2022-09-06 14:33:19 INFO i.a.w.t.TemporalAttemptExecution(get):131 - Stopping cancellation check scheduling...

Hey could you share the version of Google search console connector.

Yes, it’s version 0.1.13

Hey can you help me with the config you have tried

we have tried to set up the source with a Google Service Account with domain-wide delegation and a Google account that has access to our Google Search console property of interest.

Got it. It looks like the start_date or end_date is not entered right