Error accessing /settings/source and /settings/destination after upgrading to .50.54


After upgrading to version .50.54, users are encountering a ‘Method Not Allowed’ error when trying to access /settings/source and /settings/destination endpoints. The error message indicates that only POST method is allowed for the URI /api/v1/source_definitions/list_latest.


I tried upgrading to .50.54 and I’m getting an error when I try looking at the the /settings/source or /settings/destination; seems to have this error:
{"message":"Method Not Allowed","_links":{"self":{"href":"/api/v1/source_definitions/list_latest","templated":false}},"_embedded":{"errors":[{"message":"Method [GET] not allowed for URI [/api/v1/source_definitions/list_latest]. Allowed methods: [POST]"}]}}
I’ve tried on 2 instances and I’m getting the same issue

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["error", "upgrade", "version-.50.54", "method-not-allowed", "/settings/source", "/settings/destination", "api"]

Downgraded a few times and it’s working again with .50.50; I tried .50.52 and it didn’t work there either. Also tried pulling the latest which seems like it should be .50.56, but that also had the same issue (and the .env file still shows .50.54 there)