Error message with GA4 connections failing


The user is experiencing issues with GA4 connections failing due to an error message ‘invalid literal for int() with base 10: ‘52.400301’’.


Hi All, perhaps you can help. I’ve been running OSS for a couple of weeks now to pull data from GA4 and Google Ads and send it to bigquery. As of last night all of my GA4 connections are failing with the following error message:
invalid literal for int() with base 10: ‘52.400301’

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["ga4-connector", "data-pull", "bigquery", "error"]

The actual float value that causes the error is different for every source.

I tried simply removing all metrics with an int value but that didnt help. I also tried switching to one of the standard reports. Some work, but some also give the same error.

is the ga4 connector the latest version? do u have normalization enable if you are using ? Ive seen this in the past where it was a normalization issue from a incorrect schema.

Yes im running 2.2.1 which should be the latest version

Where can i find the normalization setting?

The connection is set to incremental, append + deduped

under transformation -> normalization:
u have raw data and normalized tabular data

I’ve got nothing configured under transformation in the connection setting. But there also doesnt seem to be a normalization setting.

<@U060J0HT31S> what destination are you using? This error is most likely to happen in normalization.

it’s going to bigquery

I just tested it out on an airbyte cloud instance and was able to confirm that it happens with the conversions:purchase metric

When I add that metric to the GA4 source it errors when I try and save it

I do not get the error when I add the “conversions” metric, or the other subsets of conversions; “conversions:add_to_cart” and “conversions:begin_checkout”

I think “conversions:purchase” has just been accidentaly mislabeled to an integer

Apologies, i just tried to add conversions:add_to_cart and conversions:begin_checkout and those give the same error

“conversions” however can still be added and shows up correctly in the replication table

next screenshot is from my OSS instance