GA4 connector: Connection test fails

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu / GCP VM / n1-standard-2
  • Memory / Disk: n1-standard-2
  • Deployment: Docker
  • Airbyte Version: 0.40.22
  • Source name/version: GA4 / 0.03
  • Destination name/version: BigQuery 1.1.9
  • Step: Connection test is failing
  • Description:
    I followed all the instructions described here but the connection is still failing.

The error message I receive is:
‘403 Client Error: Forbidden for url:

  • I am using a json service account to connect to the service.
  • I gave viewer permission to the email of the service account (Property level not account level).

Thanks for your help.

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

The email of the service account needs to be added on the account level. When it’s added on the property level it doesn’t work.

@ marcosmarxm: It would be great to update the documentation here

I’ve created a docs improvement request, please leave a thumbs up or comment to help with prioritization. Thanks for the input.

Hey guys!

I finally added the requested information to the docs.

@datasquad-ai do you think this information will prevent similar issues for new users?

Just in case anyone has any further issues.
You need to make sure that in the Service account that the Google Analytics Data API is enabled.
When I was following the setup and the links I ended up enabling the Google Analytics API which doesn’t work when you’re using the GA4 connector.