Error on Normalization at Source MYSQL

Hello, I’m using an instance in oracle.
Processor: ARM Ampere A1
Airbyte Open Souce: 0.40.4
app: Docker App (Docker Inc., v0.9.1-beta3)
buildx: Docker Buildx (Docker Inc., v0.9.1-docker)
compose: Docker Compose (Docker Inc., v2.10.2)
Server Version: 20.10.18
Operating System: Oracle Linux Server 8.6
OSType: linux
Architecture: aarch64

I connected Facebook as source and MySQL 8.0.30 as destination, but the sync does not end when I select the option: Normalized tabular data.

If I select “RAW Data (JSON)” the sync is successful.

How can I resolve this error? I have already connected another PostgreeSQL instance from Amazon AWS and the same error also occurs.

Attached are the error logs

logs-111.txt (158.9 KB)

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hello Dante, sorry the delay to return to you.
I found this error:

2022-09-19 00:52:15 e[32mINFOe[m i.a.w.g.DefaultNormalizationWorker(run):57 - Running normalization.2022-09-19 00:52:15 e[32mINFOe[m i.a.w.n.DefaultNormalizationRunner(runProcess):137 - Running with normalization version: airbyte/normalization-mysql:0.2.202022-09-19 00:52:15 e[32mINFOe[m i.a.c.i.LineGobbler(voidCall):83 - Checking if airbyte/normalization-mysql:0.2.20 exists...2022-09-19 00:52:15 e[32mINFOe[m i.a.c.i.LineGobbler(voidCall):83 - airbyte/normalization-mysql:0.2.20 was found locally.2022-09-19 00:52:15 e[32mINFOe[m i.a.w.p.DockerProcessFactory(create):119 - Creating docker container = normalization-mysql-normalize-111-2-dnapq with resources io.airbyte.config.ResourceRequirements@12f933d0[cpuRequest=<null>,cpuLimit=<null>,memoryRequest=<null>,memoryLimit=<null>]2022-09-19 00:52:15 e[32mINFOe[m i.a.w.p.DockerProcessFactory(create):163 - Preparing command: docker run --rm --init -i -w /data/111/2/normalize --log-driver none --name normalization-mysql-normalize-111-2-dnapq --network host -v airbyte_workspace:/data -v /tmp/airbyte_local:/local -e DEPLOYMENT_MODE=OSS -e AIRBYTE_ROLE= -e WORKER_ENVIRONMENT=DOCKER -e AIRBYTE_VERSION=0.40.4 airbyte/normalization-mysql:0.2.20 run --integration-type mysql --config destination_config.json --catalog destination_catalog.json2022-09-19 00:52:15 e[32mINFOe[m i.a.w.g.DefaultNormalizationWorker(run):81 - Normalization executed in 0 seconds.2022-09-19 00:52:15 e[42mnormalizatione[0m > [FATAL tini (7)] exec /airbyte/ failed: Exec format error

Looks your Airbyte server failed to run the shell script that triggers normalization. Are you able to test using other instance besides Oracle?