Error : Pickling client objects is explicitly not supported


I am using an Open Source Airbyte Instance created and upheld by a different Team than the one I am on; this means I don’t know the specifics about how the instance is created or deployed.

They have already implemented a working Sync between Salesforce → Big Query.
I wanted to replicate that, just with my own Big Query instance at the end, putting in identical values wherever possible, except of course for the Destination.

But while the original Sync works, I get the error depicted in the Title everytime and I can’t figure out why that is, nor does the Team who implemented the Airbyte Instance (of course I’ve asked them first :slight_smile: ), so throwing my plea here is my last option for maybe figuring out what the problem is.

The Full Logs are here:
0d8eb8fd_536b_4efa_a117_8bcba37a34ef_logs_107_txt.txt (334.9 KB)

Thank you for reading,
I can’t really answer most of the Placeholders below, I simply don’t know

  • OS Version / Instance: MacOS
  • Airbyte Version: Cloud 0.40.18
  • Source name/version: Salesforce
  • Destination name/version: Big Query Präsentation
  • Step: This happens during sync. It attempts and fails 3 times.
  • Description: see above

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

From logs:

2023-02-13 09:09:35 e[1;31mERRORe[m i.a.w.i.DefaultAirbyteStreamFactory(internalLog):116 - Exception attempting to access the Gcs bucketStack Trace: The specified key does not exist. (Service: Amazon S3; Status Code: 404; Error Code: NoSuchKey; Request ID: null; S3 Extended Request ID: null; Proxy: null), S3 Extended Request ID: null

Are you trying to use the Loading Method with GCS Buckets? If yes, can you try to use the standard insert?

Okay setting it to Insert did work, thank you :+1:
But I’m not clear on why, it should have just as well have worked with the buckets, since there already is a sync active using them which is working
It’s not that relevant however.