Error in syncs after upgrading

Hi Team,

We had Airbyte v0.40.3 and MySQL source v0.6.8 and BigQuery destination v1.1.16 and we were syncing with Increment | Deduped + History and the syncs were successful. After having an issue with long loading of connections, we decided to upgrade Airbyte and source and destinations to the latest versions. However, not only didn’t fix the slow connections issue, all connections’ syncs now fail with this error:

logs-17746.txt (15.8 KB)

Even the Resetting connection and source get below error

And we inevitably started creating new sources and new connections.

But now even after several minutes, the connection page is not loaded at all!!

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
Best,
The Community Assistance Team

This was corrected in https://github.com/airbytehq/airbyte/pull/16555 but not published yet, next release of Airbyte will fix it.

Hello Marcos,
Even after upgrading to v0.40.7 when I want to delete a source, I get this error:
http://localhost:8000/api/v1/sources/delete

delete error stack trace.txt (64.7 KB)

And when I delete a connection it returns back again.

Sorry delay here Arash. I’ll test it and return to you.