Error querying api/v1/web_backend/connections/list endpoint


Error message ‘Ooops, something went wrong’ on Airbyte home screen due to failed attempt to query api/v1/web_backend/connections/list endpoint resulting in a 504-gateway_timeout error when using Postman.


Folks, airbyte is showing a “Ooops, something went wrong” on the home screen. Seems the error happens cause of a failed attempt to query api/v1/web_backend/connections/list endpoint. If I try to POST to this endpoint using postman, I receive a 504-gateway_timeout error. Any ideas? :pray:

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["error", "querying-api", "504-gateway-timeout", "postman"]

This what our UI shows:

Both are getting a 504 gateway, do you have a lot of connections? Sometimes you need to configure the cloud provider timeout to allow bigger times to allow network communications. What happen if you try to open the destination or the builder?

Builder works <@U02TQLBLDU4>, but destinations and sources throw the same exception. We do have a lot of connections in production, our QA and Staging environments (fewer connections) continue to work normally.

Do you know how to change this provider timeout on a helm deployment? Which parameter should we look for?

<@U02TQLBLDU4> any updates on this? :pray:

This is not a helm configuratoin and more a gateway in the cloud provider to be increased

I’m trying to play with the timeouts here, in the meanwhile, I can see many idle sessions in the database, not sure how it is related. Other than that, This UI message was showing up sometimes, but since last Wednesday we can’t open Airbyte connections, sources or destinations, no matter how hard we try.

<@U02TQLBLDU4> we increased an internal load balancer timeout and it worked, any suggestion on how to make this API return faster? It takes around 2 minutes now.