Error when publishing custom connector


Error message ‘Could not validate your connector as specified: Unknown error (http.426.2tUHW1ouq7tHXcc5Wqz31q)’. Looking for insights on resolving the issue.


Hi all. I’m trying to publish a custom connector to my workspace, and no matter what YAML I add to the editor, I get the following error:

Unknown error (http.426.2tUHW1ouq7tHXcc5Wqz31q)
To resolve errors, ensure that the YAML is structured as described in the docs.```
Does anyone have any insight into this?



This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. [Click here]( if you want to access the original thread.

[Join the conversation on Slack](

["error", "publishing-custom-connector", "yaml", "validation"]

This error seems to be there no matter what YAML I use. I’ve tried adding the sample yaml from the docs:

    description: A stream whose behavior is described by a set of declarative low code components
    type: object
    additionalProperties: true
      - type
      - retriever
        type: string
        enum: [DeclarativeStream]
        "$ref": "#/definitions/Retriever"
        definition: The schema loader used to retrieve the schema for the current stream
          - "$ref": "#/definitions/InlineSchemaLoader"
          - "$ref": "#/definitions/JsonFileSchemaLoader"
        definition: The field of the records being read that will be used during checkpointing
          - type: string
          - type: array
              - type: string
        definition: A list of transformations to be applied to each output record in the
        type: array
            - "$ref": "#/definitions/AddFields"
            - "$ref": "#/definitions/CustomTransformation"
            - "$ref": "#/definitions/RemoveFields"
        type: object
        additional_properties: true```
And I get the same thing. We've deployed via Helm and I've tried to check the pod logs, but I can't see an error or anything there that would help me understand the issue

Is there a browser networking error you can get more info from? the 426 is quite a strange error code

What browser are you using to access it? Any firewalls or anything of note between your browser client and the deployed instance?

I’ve done some digging here and managed to find the following error in the Worker logs:
Failure executing: POST at: <>. Message: admission webhook "<|>" denied the request: failed to run injection template: failed parsing generated injected YAML (check Istio sidecar injector configuration): strategic merge: map: map[] does not contain declared merge key: name
I can’t create the custom connector by importing the yaml, so I’ve created a simpler version of it via the UI in the Connector Builder. Then I’ve tried to create a source using that custom connector. That fails, and this error shows in the Worker pod logs.
I’m not clear what the root cause of this error is or how to resolve it, would you have any insight on this? :slightly_smiling_face:

When I create a custom connector via YAML, or when I create a Source using a Custom Connector and hit “test”, what does Airbyte do in the background? It looks like it’s trying to spin up a pod. If we could understand what happens in the background, we might have a better understanding of where this is failing.

I have a full stacktrace of logs from the worker pod which I can send, if that would be helpful? :slightly_smiling_face:

<@U047ANT3J84> Would it be helpful for me to send the logs? This is a blocker for us at the moment

Hi! I’m honestly not very familiar with what happens under the hood when running test in the connector builder. I do know that this is error (not being able to run any yaml in the connector builder) is definitely not standard, so feels like something odd in your deployment most likely. It almost feels like you could be using an airbyte version not aligned with a helm chart version? Or something weird about an istio version

Thanks Ella, would anyone else on your team be able to give me more information about what happens under the hood when running “test” in the connector builder? The more we understand what needs to happen, the more we can understand what’s being blocked