Error with Google Drive connector authentication


The user is facing an issue with the Google Drive connector authentication. The error log indicates that no streams are available for the source SourceGoogleDrive, suggesting a problem with permissions. The user has confirmed that the key works for other connectors and that Google Drive API is enabled.


Hi, newbie on Airbyte her. I was triying the google drive connector and after following the steps for Service Account Key Authentication on Airbyte Open Source i got this error log:
2024-02-22 08:45:51 platform > ----- START CHECK -----
2024-02-22 08:45:51 platform > Using default value for environment variable SIDECAR_KUBE_CPU_REQUEST: ‘0.1’
2024-02-22 08:45:51 platform > Using default value for environment variable SOCAT_KUBE_CPU_REQUEST: ‘0.1’
2024-02-22 08:45:51 platform > Using default value for environment variable LAUNCHDARKLY_KEY: ‘’
2024-02-22 08:45:51 platform >
2024-02-22 08:45:51 platform > Checking if airbyte/source-google-drive:0.0.9 exists…
2024-02-22 08:45:51 platform > airbyte/source-google-drive:0.0.9 was found locally.
2024-02-22 08:45:51 platform > Creating docker container = source-google-drive-check-fa62129a-8c34-4bad-86ef-c5c072b0976e-0-umuos with resources io.airbyte.config.ResourceRequirements@e1fed9b[cpuRequest=,cpuLimit=,memoryRequest=,memoryLimit=,additionalProperties={}] and allowedHosts null
2024-02-22 08:45:51 platform > Preparing command: docker run --rm --init -i -w /data/fa62129a-8c34-4bad-86ef-c5c072b0976e/0 --log-driver none --name source-google-drive-check-fa62129a-8c34-4bad-86ef-c5c072b0976e-0-umuos --network host -v airbyte_workspace:/data -v /tmp/airbyte_local:/local -e DEPLOYMENT_MODE=OSS -e WORKER_CONNECTOR_IMAGE=airbyte/source-google-drive:0.0.9 -e AUTO_DETECT_SCHEMA=true -e LAUNCHDARKLY_KEY= -e SOCAT_KUBE_CPU_REQUEST=0.1 -e SOCAT_KUBE_CPU_LIMIT=2.0 -e FIELD_SELECTION_WORKSPACES= -e USE_STREAM_CAPABLE_STATE=true -e AIRBYTE_ROLE=dev -e WORKER_ENVIRONMENT=DOCKER -e APPLY_FIELD_SELECTION=false -e WORKER_JOB_ATTEMPT=0 -e OTEL_COLLECTOR_ENDPOINT=http://host.docker.internal:4317 -e FEATURE_FLAG_CLIENT=config -e AIRBYTE_VERSION=0.50.50 -e WORKER_JOB_ID=fa62129a-8c34-4bad-86ef-c5c072b0976e airbyte/source-google-drive:0.0.9 check --config source_config.json
2024-02-22 08:45:51 platform > Reading messages from protocol version 0.2.0
2024-02-22 08:45:53 platform > Check failed
2024-02-22 08:45:53 platform > Check connection job received output: io.airbyte.config.StandardCheckConnectionOutput@484c022[status=failed,message=‘No streams are available for source SourceGoogleDrive. This is probably an issue with the connector. Please verify that your configuration provides permissions to list and read files from the source. Contact support if you are unable to resolve this issue.’,additionalProperties={}]
2024-02-22 08:45:53 platform >
2024-02-22 08:45:53 platform > ----- END CHECK -----
the key works, i used it on other connectors, and i checked the permissions in the folderand google api drive is enabled.
Any idea how to solve this?

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["google-drive-connector", "authentication-error", "permissions", "google-api-drive", "service-account-key"]

It seems a file format error or something like that, as it performs a rgood ead on Google Drive account.

Which file are you ingesting ? CSV?

yes csv, I tried, whit only 1 csv file in the folder, whit google sheets, json and parquet too and not working. Tried too whit varius csv and still not working

for csv maybe check the encoding, this was an issue for me

using notepad++ it says its utf-8

hmm then the default one should work

tried utf-8, ansi, utf-16 le boom and utf-16be boom and doesnt work either

I m sorry Guillermo, but i think it is something else