Freshdesk connector Incremental sync mode not working

Hi, I am trying to run Incremental Append sync mode with Freshdesk but it does not work correctly.
I have 16 contacts in Freshdesk which are emitted in the first sync, But when I run the second sync without any change in the data it still emits one records.

Destination : Redshift
Airbyte Version : 0.40.06
Stream replicated : contacts
Transformation : Normalization
logs-836.txt (44.5 KB)
logs-837.txt (44.5 KB)

Hello, can you check the new record in your destination and see the cursor_field and compare with the data you have in the Freshdesk?
They are the same?

This is the data in my destination “Tom” is replicated again in second sync even though nothing changed. Cursor field is “updated_at”.
Entries in my freshdesk are 16 contacts

Are you querying the contacts table or contacts_scd table? Can you confirm it?

I ran the test account and got similar problem with updating always 1 record for new syncs.

But in my contactstable I don’t see the duplicated because normalization removed it.