Google Ads: Wrong IDs to S3

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Linux/UNIX
  • Memory / Disk:
  • Deployment: Are you using Docker or Kubernetes deployment? no, ec2
  • Airbyte Version: What version are you using now? 0.40.8
  • Source name/version: Google Ads
  • Destination name/version: S3
  • Step: The issue is happening after sync, data is in corrupted.
  • Description: On Google Ads all entity IDs are 64-bit signed integers. After the sync, IDs from my S3 bucket don’t match Google Ads IDs.

GAQL: SELECT,,,,,,, metrics.cost_micros, metrics.clicks, metrics.impressions, metrics.conversions FROM ad_group_ad WHERE =

Destination Table Name: ad_report_custom

Screenshot 2022-10-12 at 12.30.45

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey is this happening after normalisation?

I think that yes.

Got it. I didn’t check it is s3. Is it possible to try with another destination?

We are using S3 and we don’t want change the destination. I will change the output format of the s3 bucket (AVRO or JSON) and try it again, but I can’t do that at the moment because I’m trying to set up a new Google Ads source with my newly created credentials, but I get this error.

{“status”:“failed”,“message”:“Check Connection Failed!”,“jobInfo”:{“id”:“1ae9a813-b3a9-473b-b1ff-64ca17bb5dd7”,“configType”:“check_connection_source”,“configId”:“Optional[253487c0-2246-43ba-a21f-5116b20a2c50]”,“createdAt”:1665750842643,“endedAt”:1665750843536,“succeeded”:false,“logs”:{“logLines”:}}}

Could you share or check the logs of server/worker?

I can’t do that…

Issue solved, I terminated the ec2 instance and created another one. Thank you for your time and help!